SEL18200 Lens Problem

Started 7 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Ken Sills
Regular MemberPosts: 494
Like?
SEL18200 Lens Problem
7 months ago

See Photo attached.  The back of the front glass element of my 18200 has developed what looks like a circular water stain.  My theory is that this element surface is concave, moisture condensed, pooled in the center of the lens, and then dried out leaving a stain.  Does this make sense to you?  I guess there's no way I can open the lens and clean it?  Send to Sony for repair?  I was touring  in Japan with the lens on some some very wet days so probably my bad.

The lens otherwise works OK, and the watermark cannot be seen in photos.

Apart from this watermark issue, I hate this lens.  I often have the problem with this lens on my NEX-6 where one or all of these happen: the image turns white, focus is lost, and the camera reports that the lens cannot be identified.  The fix is always to reset the lens or reboot the camera. I have no similar problems with my 1650 or 1018.  This problem has been well documented in this forum but to my knowledge, there is not definitive resolution.  I should not have this issue with a system that cost more than $1500.

Sony SEL18200 with interior water stain

Sony Alpha NEX-6
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
(unknown member)
(unknown member)
(unknown member)
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow