Intermittant ERR 70 -- 5D Mark III

Started Mar 25, 2012 | Discussions thread
BobCook
New MemberPosts: 5Gear list
Like?
Re: Probably not a camera problem
In reply to GlannAK, 3 months ago

Hi, For what its worth I have been experiencing Error 70 problems with my Canon 7D after I did two things; Updated the firmware from V2.0.0 to V 2.0.5 and I also ran some software to find out the shutter count.

I suspect the shutter count software was the problem. I used EOSMSG software.

To get the shutter count you run the software then connect the camera via a USB cable. I also re-installed V2.0.0 of the firmware in case this was the problem. Error still occurred. I could operate the camera OK but after taking a shot I would get the error message on the screen. I could see the images on the card.

While researching the Error 70 problem I saw a thread where the poster had fixed the problem by playing with the HDMI output (plug/unplug the cable). This steered me to suspect the USB cable connecting the camera to the computer for the shutter count reading. So, I re-connected the camera using the USB cable, turned the camera off, then disconnected the USB cable. Turned the camera on and bingo! all is OK.

Maybe the shutter count software left the USB part of the camera in some 'open' not 'closed' state (just me guessing) and the routine I used reset it back to normal.

I have now re-installed V2.0.5 of the firmware and all is OK (so far)

Hope I have fixed it permanently and if so, I hope this helps someone.

-- hide signature --

Bob Cook

 BobCook's gear list:BobCook's gear list
Canon EF 20mm f/2.8 USM
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow