Sony RX-100 quits on Shutter Release

Started 4 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Dennis2
Regular MemberPosts: 183
Like?
Sony RX-100 quits on Shutter Release
4 months ago

I bought a car charger for my RX100 and used it on my camera.... turns out .. it apparently damaged the operation of my camera. I say this because ... my issue started happening immediately after some charging with that particular charger, and that same charger refused to charge my cell phone, so I think there is something off with the charger or the cord, and I so returned the that charger to the store.

Back to my camera -- It seems to be operating just "fine", except when I go to take a photo. When I press the shutter release button, these two things happen: first, the camera does its characteristic click as it always does, and the iris closes (as seen from the outside of the lens looking in), but it does not open back up. Second, the screen goes black, but the camera is still on (I can see the faint glow of the LCD).  That's it.  The camera does not turn off after that when I press the power button and is non-responsive  I have to take out the battery, put it back in, and then turn off the camera.  When I do, it again appears to operate fine, except when I try to take a photo.

I am thinking of sending this unit for a repair. Before I do I wanted to see if there are any known issues of this particular type that maybe I can fix at home ...

Sony RX100
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow