Have Fuji fixed the lens mount wiggling problem on XE2 and XT1?

Started 6 months ago | Discussions thread
Jim King
Veteran MemberPosts: 7,716Gear list
Like?
Re: What lens mount problem ?
In reply to nick_webster, 6 months ago

nick_webster wrote:

I've got an X-E1 and I can mount a 300mm f2.8 lens with cheap adapter and there's no wiggle, jsut as there isn't with my X-T1.

It's a bit disingenuous to suggest that just because your camera has this (non) issue that all X-E1s have it.

Nick

+1.  The phrasing of the OP is akin to "When did you stop beating your wife."  No need for such a provocative title.

-- hide signature --

Jim King - Retired Colormonger - Suburban Detroit, Michigan, USA; GMT -4h (EDT)
Pentaxian for over 50 years.
* * * * *
There is hardly anything in the world that some man cannot make a little worse and sell a little cheaper, and the people who consider price only are this man's lawful prey.
- John Ruskin
* * * * *
A fanatic is one who can't change his mind and won't change the subject.
- Sir Winston Churchill
* * * * *
The difference between genius and stupidity is that genius has its limits.
- Albert Einstein

 Jim King's gear list:Jim King's gear list
Fujifilm X20 Leica M9 Ricoh GXR S10 24-72mm F2.5-4.4 VC Ricoh GXR Mount A12 Ricoh GXR A16 24-85mm F3.5-5.5 +18 more
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
(unknown member)
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow