S120 Battery Issue during/after Video

Started 5 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
vbjeff
Junior MemberPosts: 41
Like?
S120 Battery Issue during/after Video
5 months ago

I just got my S120 this weekend and I am having an issue with the battery indicator during/after taking a video.  When start taking a video for less than a minute, the battery level drops significantly and stays low until I turn off the camera.  When I turn the camera back on, the level seems to return to the proper value.  After 50 photos and several minutes of video, the camera battery level dropped one bar while taking photos, but if I start taking a video it drops to the bottom and starts flashing red (but seems to still work).  If I turn off the camera and then turn it back on to take photos, it remains at one bar less than full.

I have seen posts elsewhere where other people were having the same issue, but no one had a solution.  I called Canon, and they said I should send it in for service.  I have never had this issue with any of my previous Canon cameras.

Has anyone else had this issue?  Does the battery need to go through several charging cycles before it is displayed accurately?  Could the type of SD memory being used cause this to happen?  I like the camera, but a constant red flashing battery indicator while taking videos does not let me know when I need to charge/change the battery.  I may exchange it if it does not improve soon.

Thanks,  Jeff

Canon PowerShot S120
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow