I Returned the K3

Started 8 months ago | Discussions thread
jhmos
Regular MemberPosts: 149Gear list
Like?
Re: I Returned the K3
In reply to rwl408, 8 months ago

rwl408 wrote:

awaldram wrote:

Looks to me as a legacy bit of buggy remediation code that was never fixed and may not even be required in the k3.

If it is simply a bug in the firmware, Pentax should have nailed it long time ago. I think it is more of a hardware design problem. Very possibly the power analog circuit design if I would venture a guess. All Pentax DSLRs seems to be very sensitive to battery ever since *ist days when off-the-shelf AA batteries were used. I believe Pentax must have looked in that direction hard and that is probably why Pentax later went with " proprietary" batteries for K-series - to have a better control of battery quality. When I bought my first DSLR, the AA battery flexibility was one factor that drove me towards Pentax. Not any more, sorry to say that.

I did think it was most likely just a firmware issue and rather hoped that was the cause. However the evidence of other people having never seen the fault started to mount, until GoremanX (who had never had the fault) attempted to reproduce it. He used the same settings as I had used to reproduce the fault, but on his camera no fault was triggered in 15000 frames.

So it seems that not all K-3 bodies are susceptible to this fault condition. The evidence does not seem to support any conditions having influence over how likely it is for the fault to occur, so I don't think I'll speculate on the possible causes any more.

 jhmos's gear list:jhmos's gear list
Pentax K-3 Pentax K100D Sigma 10-20mm F4-5.6 EX DC HSM Pentax smc DA* 300mm F4.0 ED (IF) SDM Sigma 70-200mm F2.8 EX DG OS HSM +10 more
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow