For Ron, Sigma 500/4.5 + Pentax 1.4tc

Started 6 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Chris Mak
Senior MemberPosts: 1,205
Like?
For Ron, Sigma 500/4.5 + Pentax 1.4tc
6 months ago

Hello Ron,
I only had the opportunity to shortly try the 1.4tc on with the Sigma 500 (on the K3) in good daylight, and I have to say that AF on this combo exceeds my expectations. Of course it is in no way as fast or snappy as the lens directly on the K3, but I was not expecting that, because the sigma is stunningly fast on the K3. AF is very accurate and sufficiently fast though, and in my case, a good notch above the AF with the sigma 1.4tc on the K5IIs, but then again: my copy of the sigma 1.4tc was probably not 100%, I had problems with detaching it from the lens, and it would sometimes just block attempts from the screwdrive motor to focus, giving a rrr-rrr-rrr sound. Nothing of that with the Pentax tc, it is beautifully built, far better than the sigma if you ask me.

The Pentax 1.4tc is also sharper than the Sigma tc, in fact, it is every bit as sharp with the sigma 500 as the lens itself, very impressive. This is what I've been waiting for as a repacement for the sigma 1.4tc. I really want the 700mm to shoot handheld. Obviously, having shot the Sigma 500 on the K3 without tc since selling my sigma tc directly after the Pentax was announced, it is far harder to shoot 700/6.7 handheld than it is to shoot 500/4.5, so I was getting spoiled. But practice makes perfect, so I'll be having the Pentax 1.4tc glued to the Sigma to get into shooting this combo again. When properly focussed, and held steadily, this combo delivers on the K3 is my first impression. Perhaps you are having issues with your Sigma 500, although I wonder what those could possibly be?

It's not all rosy though: I'm having issues with heavy underexposure with this combo, in all exposure metering settings, having to dial in as much as +1ev, but also getting very inconsistent exposure, with one shot being 1/400s (AV setting), and the next directly after (same scene) 1/125. I have no idea what is causing this, I first thought that the K3 might be exposing as if only the lens was on, but minimum aperture does say: 6.7. I hope there is a solution, but it might also be that the loss of contrast with this combo lets the K3 expose too far to the left. The sigma lacks a bit of contrast by default anyway. Although this would not explain the randomness.

Anyhow, the tc is all I hoped for, with the sigma tc out of production and having a bad copy. It's beautifully made with perfect fit, and optically sharper than I would expect from a 1.4tc. I'll be eager to hear if you recognize the exposure issues.

Chris

Pentax K-5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow