I Returned the K3

Started 9 months ago | Discussions thread
Barry Pearson
Veteran MemberPosts: 5,594Gear list
Like?
Re: I Returned the K3
In reply to RPulley, 9 months ago

RPulley wrote:

Good.

Now you can get back to your photography, and the forums can move on past your very long-winded and overly dramatic descriptions of your problem....

On Wednesday, I had what appears to be exactly this problem. I was shooting motor sports in burst mode and suddenly my K-3 started making a noise as thought the mirror was moving up and down as fast as it could. I switched it off, and after a short time it stopped. The I carried on in burst mode.

I've owned nearly all Pentax flagship dSLRs, and this is the first one with any such problem. (I shot over 60,000 DNGs on my K-5IIs last year without problems). I pre-ordered my K-3, so it is an early one, but has not done this before. I was using the battery grip with 2 part-used (that day I shot about 2,500 DNGs) LI-190 batteries that I've been using for some time without problems. I'm using the latest 1.03 firmware (and probably had the Pentax 1.4x Teleconverter on at the time).

This is a real problem. I'll add my name to the thread identifying people who've experienced this problem. It mars an otherwise super camera, because I now have less confidence that I can rely on it. (Fortunately I keep my K-5IIs available as a back-up).

Battery grip and 2 batteries that had been used a lot that day - is this part of the pattern for this problem?

 Barry Pearson's gear list:Barry Pearson's gear list
Pentax K-7 Panasonic Lumix DMC-GF1 Pentax K-5 Pentax Q Pentax K-5 IIs +22 more
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow