60D problem while shooting the stars.

Started 2 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Raul Mkryan
New MemberPosts: 16
Like?
60D problem while shooting the stars.
2 months ago

I bought a 60D few months ago and decided to take some test shots of the night sky from my roof, I don't have any equipment whatsoever, not even a tripod...

The issue is that the images that I took were completely unusable, awfully noisy and there's some other weird problem too, I'll try to link some of my shots for you to see.

I was using the kit lens 18-55mm ii (I don't have money to get new lenses yet, but I sure do plan to do so).

30s, f3.5, 3200

20s, f3.5, 3200. If you zoom in on the trees yo'll see that it's just... I don't know, my mobile phone would take better pics than that.

20s, f3.5, 3200. This one is edited in Camera Raw.

20s, f3.5, 1600. As you can see even at 1600 ISO it looks ugly.

There's awful amount of light pollution to take pictures of stars, I know, but if there was no pollution then I can't imagine how much worse the noise would've been.

I know that it's an old camera but as far as I know 70D which is new and replaces 60D has the same noise performance.

Again, I know that the conditions weren't suiting astrophotography but I sure did not expect to get such results...

Any help would be appreciated.

Thanks in advance,

Raul

Canon EOS 60D Canon EOS 70D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow