E-M1 just back from repair - hmmm

Started 7 months ago | Discussions thread
jennajenna
Senior MemberPosts: 1,156
Like?
Re: E-M1 just back from repair - hmmm
In reply to brick33308, 7 months ago

brick33308 wrote:

I sent my E-M1 in a couple of weeks ago because it had completely locked up which I reported here: http://www.dpreview.com/forums/post/53036673

When I sent the camera in, I sent in only the body, and didn't send back the original box or anything else. Today I got what appears to be another E-M1 which appears to be new, full packaging, new battery, charger, etc. I checked and it has 121 shutter clicks on it.

On the one hand I suppose I should be thrilled that I got a brand new camera. But I can't erase the nagging doubt of whether I would have been better off had they repaired my old camera, addressing the specific problem I had to ensure it never happens again. Instead I've got what appears to be a brand new off the shelf camera (although as I said with 121 clicks - probably just normal factory testing?) and in the back of my mind am wondering if and when I'll experience the same lock up problem. Even worse, if it happens while I'm on vacation (we're going to Iceland in July) then I'll be up the creek so to speak.

Any thoughts?

I hear what you are saying; but unless your problem was an assembly wide defect you are indeed better off. Chances are your last em1 had a problem solely unique to it. Getting a brand new camera would be my choice over repairing a likely one-off problem.

Besides now you will see in the next few months if the same problem comes back - i doubt it will.

congrats!!

Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow