Dead Lexar CF Card on 5DMkIII

Started Feb 20, 2014 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
John Vant Land
Contributing MemberPosts: 526Gear list
Like?
Dead Lexar CF Card on 5DMkIII
Feb 20, 2014

Halfway through a shoot Tuesday my Lexar Professional 1000X 16GB CF suddenly died and my new images automatically went to my backup SD card.

I lost a couple of dozen shots on the bad card before the changeover and I was fortunate I could go back and retake them.  I came home, couldn't get the card to mount on my computer.  So I reinserted the card in my camera and it wouldn't even format.

I found Lexar support and downloaded their recovery software (Imagerescue4) but since the card wouldn't even mount, it couldn't see it.  I e-mailed Lexar and they wanted to know my computer OS and card reader info.

I explained that the card wouldn't even mount and that all of my other cards work fine in my SanDisk reader and my computer and OS are up to date.  I can almost see them trying to blame the computer or reader.

The card is less than 4 mo. old.

Any advice?  Has anyone else had a similar problem and is Lexar good about their warranty of fixing or replacing?

BTW, if anyone knows of another forum that this could better be listed on, let me know.

Thanks,

John

-- hide signature --

Enjoying God and His Creation.

 John Vant Land's gear list:John Vant Land's gear list
Canon PowerShot G12 Canon EOS 5D Mark III Canon EOS 7D Mark II Canon EF 50mm f/1.8 II Canon EF-S 10-22mm f/3.5-4.5 USM +6 more
Canon EOS 5D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow