Metz 24AF-1 randomly fires full power or not at all.

Started 5 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
needmoretoys
Regular MemberPosts: 396Gear list
Like?
Metz 24AF-1 randomly fires full power or not at all.
5 months ago

I just bought a Metz 24AF-1 for Panasonic/Olympus from Amazon for my FZ200. It came today and I tried 39 test shots around the house, including a few macro with my Canon 250D close-up lens. Of the 39, 6 fired full power and 2 didn't fire. The EXIF data for all shots shows that the flash was used.

Of the 6 that fired full power and were overexposed, 4 were in manual mode and 2 were in aperture priority. Of the 2 that didn't fire and were greatly underexposed, 1 was in manual mode and 1 was in aperture priority. The one in aperture priority was underexposed by 4 EV and the one in manual mode was underexposed by about 8 EV. Of the 8 shots, a 2nd shot without changing any settings or the subject resulted in a correct exposure. Seven of the 8 misfires were shot in auto flash mode, but the last one, a non-fire, was in forced flash mode.

Three were also shot in program mode and all were fine. The final 10 shots were also fine, as were the first 5 shots. There's nothing special about the 8 bad flashes, so I'm stumped. Any ideas what could be the problem.

 needmoretoys's gear list:needmoretoys's gear list
Panasonic Lumix DMC-ZS7 Panasonic Lumix DMC-FZ200 Olympus XZ-2 iHS Canon EOS 100D Canon EF 200mm f/2.8L II USM +6 more
Panasonic Lumix DMC-FZ200
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow