7D USB port suddenly didn't function

Started 6 months ago | Questions thread
Sherwin V Ubaldo
Forum MemberPosts: 54Gear list
Like?
Re: 7D USB port suddenly didn't function
In reply to Joe Pa, 6 months ago

Okay, I tried to wait for a minute or two but all three computers that we have connected the 7D with has no response, not even a notification sound. So, the USB port probably is dead. All functions of the camera thou is working flawlessly except for this USB now.
We never did use any USB Hub it has always been directly connected to the laptop. One thing though we use a meter-long extension USB cable together with the original USB cable provided by Canon. Could this be the reason why, but we have used the same cables last year with the same laptop and camera without any problems until this year's shoot on the 2nd day.
Awhile ago I was playing around in the studio and connected my 30D with the same cables directly to the desktop's motherboard USB port and noticed that it draws a lot of power rendering my keyboard and mouse without power, removing the 30D brings back the keyboard and mouse to normal operation. That is weird as I have never observed it before when we were still using the 30D for tethered shoots. Gladly the 30D's USB port was not damaged.
I guess the 7D's usb port though is dead.

-- hide signature --

Just do your best at all times. Sick or not.

 Sherwin V Ubaldo's gear list:Sherwin V Ubaldo's gear list
Canon EOS 7D Canon EOS 60D Canon EOS 6D Canon EF 50mm f/1.8 II Canon EF 70-200mm f/4.0L USM +7 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow