PIX 2015

7D USB port suddenly didn't function

Started Feb 6, 2014 | Questions thread
Shop cameras & lenses ▾
Joe Pa
Senior MemberPosts: 1,701Gear list
Like?
Re: 7D USB port suddenly didn't function
In reply to RS_RS, Feb 10, 2014

RS_RS wrote:

Joe Pa wrote:

There is a potential problem when cameras are connected through USB hubs. Some cameras can demand a lot of power and if the hub isn't a powered hub or not capable of powering all of the devices connected to it, it can cause power surge reversal which blows the USB port on the camera and possibly additional circuitry in the camera.

I would expect a camera to be powered by its own battery when connected as a USB client, and consequently not to need to draw power from the USB connection. Do you have any evidence for EOS bodies that this is not the case?

I always connect my camera directly to the PC but for those that use hubs, make sure they are powered hubs and can deliver the required power to all devices plugged in.

I do not have evidence, but I know two people had this exact problem with different cameras after receiving an error message about too much power being drawn on the hub.   I also have powered USB devices that require a powered hub or direct connection to PC USB port.

 Joe Pa's gear list:Joe Pa's gear list
Canon PowerShot D30 Canon EOS 5D Mark III Canon EOS M Panasonic Lumix DMC-GH3 Canon EOS 6D +32 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow