Sony A58 "camera Error"

Started 6 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
barnybullet
Forum MemberPosts: 62Gear list
Like?
Sony A58 "camera Error"
6 months ago

Just bought a second hand A58 that was like new as if it had ever been out the box.

Took it out and was working fine (used my 16-50mm f2.8 from my A77 first then used my minolta 70-210 F4 beercan)

Got home and went to plug camera in to look at the photos and when i did it just came up "camera error turn off and on again"

Now i see this happens quit often on other models and appears to be a servo issue but trying to see which part is causing it i think it might be the aperture servo.

If i turn the camera on with any lens attached it goes straight to this error.

If i turn the camera on without a lens attached it works fine and will fire.

If i attach the lens but dont quite turn it enough to click into place it will work fine as manual focus with whatever the aperture is set at. As soon as i click it into place though it then errors

If i do this but with my beercan and i put the focus somewhere mid range as soon as it clicks into place in the half a second it takes to error it will focus the lens to infinity so looks like the focus motor is fine

Any ideas??

Other issues is to get it repaired eve though it is less than a year old i assume sony wont repait it for free with me having bought it second hand

 barnybullet's gear list:barnybullet's gear list
Sony Alpha DSLR-A100 Sony SLT-A77 Sony SLT-A58 Sigma 18-250mm F3.5-6.3 DC OS HSM Sony DT 16-80mm F3.5-4.5 ZA Carl Zeiss Vario-Sonnar T* +6 more
Sony SLT-A58 Sony SLT-A77
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow