A7/A7R Light leaks reported + White Orbs issue?

Started 6 months ago | Discussions thread
richard NO
Contributing MemberPosts: 794Gear list
Like?
Re: Leak confirmed on my A7 (1 photo)
In reply to SQLGuy, 6 months ago

SQLGuy wrote:

Just tried mine under some direct light in the kitchen (25600, 30sec).

First test was with a body cap on. The result was a fairly uniform red frame.

Second was same setup in a dark room, to see whether light leak was the cause. Sure enough, this was dark grey instead of red.

Third was back under the lights with the kit zoom and its lens cap and hood. That was uniform almost black.

Last test was with a Fotasy Canon FD adapter and an nFD 35/2 with its cap on. This resulted in an almost black screen with a bit of a dim red streak in one corner. I guess the adapter does leak. It should be noted that the E-mount end of the adapter has thinner parts, especially the bayonet and tube wall, than the native kit zoom's mount.

-- hide signature --

A7 with kit lens and a number of legacy lenses (mostly Canon FD)

I also tested first with the cap "untaped", more leak so i taped the whole thing with plastic foil under to avoid a sticky lens:) no adapter used. I dont like this! The lenses are weather sealed but not the mount is not light sealed, sigh....

-- hide signature --

Photography for me is not about recreating what i saw through
the viewfinder but to show people the way i want to see the world
Cheers!
Richard Larssen http://www.flickr.com/photos/uberdogleg/
-------------------

 richard NO's gear list:richard NO's gear list
Sony RX100 Sony Alpha NEX-6 Sony Alpha 7 Sony a6000 Sony E 10-18mm F4 OSS +1 more
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
(unknown member)
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow