Problem with Sony A7, reflections on the sensor.

Started 9 months ago | Discussions thread
captura
Forum ProPosts: 14,702Gear list
Like?
Re: Problem with Sony A7, reflections on the sensor.
In reply to Brianroger, 8 months ago

Brianroger wrote:

Hi folks.
Using A7 last night with a Leica Summarit 35mm at various combinations between f2.8 - f8. No filter on the lens. Purple blotches and possibly artifacts, or am I being paranoid/not very bright?

Taken last year with Sony NEX-5N. SEL 16mm at f2.8 (I know it´s supposed to be f5.6 minimum!)

Never had an issue with what I suspect from reading this excellent forum are either artifacts or possibly reflections on the sensor with my beloved NEX 5N. My questions to all you helpful and well-informed contributors are:

Purple blotches?

More blotches

No problem with Sony A7 and Leica Summarit 35mm here.

1) What can be done to eradicate/minimse the purple blotches
2) Would shooting in RAW help?
3) Am I doing something stupid?
Uploaded photos all taken with Sony A7 and Leica Summarit 35mm between f2.5 and f8
Thanks in advance for helpful comments.
PS The Aurorae will be out again toninght, so hoping to try again. We shall persevere...

Problem with the sensors, should Sony do a recall?

Another problem, or are they related? ; A7/A7R Light leaks reported....

http://community.sony.com/t5/Alpha-NEX-Cameras/A7-A7R-Light-leaks/td-p/254835

 captura's gear list:captura's gear list
Fujifilm X10 Sony Alpha NEX-7 Samsung NX1000 NEX5R Olympus M.Zuiko Digital ED 40-150mm 1:4-5.6 R +10 more
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
5N?New
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow