Problem with Sony A7, reflections on the sensor.

Started 9 months ago | Discussions thread
Brianroger
New MemberPosts: 16Gear list
Like?
Re: Problem with Sony A7, reflections on the sensor.
In reply to PRESENZA76, 8 months ago

Hi folks.
Using A7 last night with a Leica Summarit 35mm at various combinations between f2.8 - f8. No filter on the lens. Purple blotches and possibly artifacts, or am I being paranoid/not very bright?

Taken last year with Sony NEX-5N. SEL 16mm at f2.8 (I know it´s supposed to be f5.6 minimum!)

Never had an issue with what I suspect from reading this excellent forum are either artifacts or possibly reflections on the sensor with my beloved NEX 5N. My questions to all you helpful and well-informed contributors are:

Purple blotches?

More blotches

No problem with Sony A7 and Leica Summarit 35mm here.

1) What can be done to eradicate/minimse the purple blotches
2) Would shooting in RAW help?
3) Am I doing something stupid?
Uploaded photos all taken with Sony A7 and Leica Summarit 35mm between f2.5 and f8
Thanks in advance for helpful comments.
PS The Aurorae will be out again toninght, so hoping to try again. We shall persevere...

 Brianroger's gear list:Brianroger's gear list
Sony Alpha NEX-5N Sony Alpha 7 Sony E 16mm F2.8 Pancake Leica Summarit-M 35mm f/2.5 Sony E 50mm F1.8 OSS +5 more
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
5N?New
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow