A7 LCD/EVF weird behavior

Started 8 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Dr hatem Ayman
Regular MemberPosts: 135
Like?
A7 LCD/EVF weird behavior
8 months ago

I just received 2 used lenses(minolta 85/1.4, and Sony 135/1.8) from a wonderful seller in Japan (http://stores.ebay.com/sunrise-camera). I was worried he wouldnt ship because I ordered them from his website not from ebay, but here they are in my hands, in perfect shape as good as new. This seller is awesome.

Anyhow I have been taking photos with both lenses day and night for 2 days, and I was extremely dissapointed with the results on the EVF and the LCD, pics looked so grainy and noisy  when I magnified them in-camera, but I just uploaded them on my laptop now and even with maximum magnification the images are relatively cleaner than on the LCD. Does anyone have an explanation for this discrepant behavior ??.

Disclaimer: Before someone shouts at me (as usual) that this is the wrong forum (this is the usual behavior in this forum), and that LCD issues are discussed elsewhere I would like to clarify that I really did look THOROUGHLY for a forum dedicated for LCD/EVF but found none.

Sony Alpha 7
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow