G16 Continuous Focus "Clicking" Noise

Started 11 months ago | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
Blakeh
New MemberPosts: 4
Like?
G16 Continuous Focus "Clicking" Noise
11 months ago

After a lot of research I decided to upgrade from a Canon Elph 300 HS to a PowerShot G16. So far I like the quality of the images I am getting from it, but there is one glaring annoyance. When the camera is in fully automatic mode (granted, I probably won't shoot in that mode all that often, but this is still something that is bothering me) there is no way to turn the Continuous Autofocus off. This results in the camera clicking (quite audibly) every second or two as it attempts to constantly refocus. Obviously I know that is what Autofocus is supposed to do, but I just can't get used to the constant (and again, what I consider quite loud) clicking.
Is this something that is wrong with my particular camera or do all G16s display this issue? I can always return it and swap it with another G16 but I'm wondering if the results will the the same. I can work around the issue by putting the camera n "P" mode and turning the Continuous Autofocus off (which is fine), but I'm more worried about the fact that there may be something wrong with the camera for it to be clicking so loud.
Any advice is much appreciated.

Thanks,

Blake

ANSWER:
This question has not been answered yet.
Canon ELPH 300 HS (IXUS 220 HS) Canon PowerShot G16
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow