So much for the EVF being insufficient for action.....

Started 9 months ago | Discussions thread
Lee Jay
Forum ProPosts: 44,652Gear list
Like?
Is the claim even true?
In reply to Ontario Gone, 9 months ago

According to Fuji Rumors, the refresh rate is 54fps which, if true, makes Fuji's claim of 0.005s (50ms) lag impossible to be true. If the readout and processing speed were both zero (which, of course, they aren't), a 54fps refresh rate means a lag of 1/54 = 0.0185s (18.5ms). Of course, readout and processing speed are not zero. In fact, I suspect they are 0.005s (and Fuji is ignoring the frame period) making the peak lag under ideal conditions (I doubt they are talking about low-light) 0.005+0.0185=0.0235s or 23.5ms. Since I measured my SX50 as having a total lag of 25ms, this is nothing to write home about especially since that 25ms lag made me unable to track a high speed subject I needed to shoot (I simply switched to an SLR and got the job done).

Add to that the claimed CIPA battery life of 350 shots (versus 920 for the Canon 70D) and you're right back to the same old EVF problems - too much lag, too much power use.

-- hide signature --

Lee Jay

 Lee Jay's gear list:Lee Jay's gear list
Canon IXUS 310 HS Canon PowerShot SX260 HS Canon EOS 5D Canon EOS 20D Canon EOS 550D +23 more
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
(unknown member)
(unknown member)
(unknown member)
NONew
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
YesNew
(unknown member)
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow