Problem with Sony A7, reflections on the sensor.

Started 6 months ago | Discussions thread
Trollmann
Senior MemberPosts: 1,158
Like?
Re: Lens fault, not sensors problem...
In reply to kimca, 6 months ago

Interesting thread!

Seems like the initial problem is reflection from the rear element of the lens (in the early digital days this was a BIG issue and it did not take lone before lens makers had all their lenses coated with superb anti reflection coatings on the rear lens element). Reflection from sensors are real, with film it was no issue - and lots of older lenses have uncoated or poorly coated rear lens elements.

Had the Minolta 2.8/16 mm fish eye (film day lens) and there was a plethoria of reflections when used with my Minolta digital camera - with film there was almost none. Simply gave up the lens as a digital alternative.

So I guess (note: I do not know) the lens is to blame and not the sensor per se.

Diffraction spikes (like rays around the sun when using a small aperture) is caused by diffraction in the aperture blades. Circular apertures cause diffraction rings and apertures with angles (like a four or five blade aperture) cause diffraction spikes (and some other not that easy to spot diffraction pattern).

There is a lot of theory about reflective sensor surfaces and diffraction but mentioning things like these on a forum usually open cans of worms. Lots of misconceptions...

Reply   Reply with quote   Complain
Post (hide subjects)Posted by
5N?New
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow