S110 Issue with exposure compensation and metering and usability

Started 6 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Clay Davis
New MemberPosts: 5
Like?
S110 Issue with exposure compensation and metering and usability
6 months ago

Hi there,

Quick background - this is only my second real camera, the first being the Canon IXUS 870 IS (SD 880) which I used heavily for 4 years until 2013 when the metering seemed to give out.

I'm having real issues with the S110. They boil down to two things:

I don't seem to get a preview for exposure compensation. I could stick it on -2 exp and the preview will look normal, and I essentially can't tell what it will look like until I take the shot. Perhaps this is normal on a more serious camera? What am I misunderstanding?

Secondly, metering. What I naturally do in a high-contrast scene is point the center at whatever I want to be exposed, half shutter, and then move the camera to frame the composition how I want it. This doesn't seem to work. For me this is a huge pain, as I don't want to be messing with the exp setting every time the lighting conditions are difficult. When I half press the shutter button it doesn't lock the shutter speed / aperture or whatever.

Both of these things worked differently (better?) on my old 870. In fact, aside from far superior quality photos and manual controls when need, I much prefer the old camera.

What am I doing wrong?

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow