Battery problem with K5II

Started 11 months ago | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
photopastor
Junior MemberPosts: 44
Like?
Battery problem with K5II
11 months ago

While in Arizona on Christmas vacation I ran one battery down.  While I used my backup battery I recharged the depleted one.  When I put the first battery back in the camera... NOTHING!  I figured the battery (less than 6 months old) went bad or there was a problem with my charger.  I believe I did use the charger on the 2nd battery with no problem after that.  Put it out of my mind until I had some time to check things out and watch carefully.

Tonight I put the "bad" battery in the charger.  In almost no time the light went out and it read as charged.  I put it in my K5II and still NOTHING.  Unhappily I figured I just got a bad battery.  But when I put my other battery in the camera after that, NOTHING.  I had just checked the battery in the camera before testing the "bad" one and the "good" battery showed a full charge and no issues.  2 minutes later it is dead in the water.

I now have a camera and 2 pentax batteries that do nothing.  Before I call Pentax, has anyone else had this problem?  Is Pentax USA service generally responsive?

Thanks for any help on this matter.

-- hide signature --

Having fun with Pentax since 1978

ANSWER:
This question has not been answered yet.
Pentax K-5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow