K30 fried after using in rain

Started 6 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Simon Devlin
Senior MemberPosts: 1,228
Like?
K30 fried after using in rain
6 months ago

Well earlier I was using the K30 with 18-55 AL WR kit lens in the rain. When I wasn't using it I put it back into the Hama hard case.

Got back to the cold car and left it in the case so it wouldn't suffer from going from cold to warm in a short period. Eventually got back to house around 1 hour later and took it out, it looked fine and worked. I actually spent a while experimenting with enlarger lenses on extension tubes and took some photos.

Took the battery out for a recharge. 3 hours later put it back in and I notice watermarks/stains inside the LCD screen. Then it gave garbled information saying f1.2 for aperture reading!!! f1.2 on a set of manual extension tubes? Then it froze and I had to take the battery out. I tried this several times over and still no change and the water-staining looks like it might be permanent.

The bad news... I think it has only 1 year warranty which ran out in December.

I bought it from Jessops online UK. There is a shop in my city...

So much for your WR advertising Pentax and marketing this as a hikers camera.

Even if it did work again this is clearly not a WR camera.

I know all about the ambiguity surrounding what WR realy means and litigation.

Any suggestions? Please don't tell me this is going in the bin with no comeback on it!

-- hide signature --

Simon
Legacy lens lover
Anarcho-primitivist and avid anti-technology advocate

Pentax K-30
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow