Err 01 on Canon T2i + Sigma 28mm 1.8

Started 10 months ago | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
yuzi92
New MemberPosts: 2Gear list
Like?
Err 01 on Canon T2i + Sigma 28mm 1.8
10 months ago

So I picked up a used lens off of eBay that wasn't as tight as my 50mm. I ended up with a Sigma 28mm 1.8 but it keeps giving me Error 01. I cleaned the contacts with a cotton swab and rubbing alcohol but it still does not work. The lens works fine and will take pictures + autofocus. The pictures save, but the error pops right up and don't let me do anything. However, the pictures save in movie mode and it doesn't give me the error—but I'd rather use the eyepiece.

I've read online that some people have had to ship it to Sigma for a new chip or firmware, but I'm having a hard time figuring out if this is the problem.
Any suggestions?

Pictures of the lens:

http://imgur.com/jMc5Cku

http://imgur.com/2ynEJZh

http://i.imgur.com/WHHr5HK.jpg

 yuzi92's gear list:yuzi92's gear list
Canon EOS 550D Canon EF 50mm f/1.8 II Sigma 28mm F1.8 EX DG Aspherical Macro
ANSWER:
This question has not been answered yet.
Canon EOS 550D (EOS Rebel T2i / EOS Kiss X4) Sigma 28mm F1.8 EX DG Aspherical Macro
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow