Banding on MKIII and Some New User Questions

Started 9 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Bob Markey II
Contributing MemberPosts: 581Gear list
Like?
Banding on MKIII and Some New User Questions
9 months ago

I just took delivery (test period prior to paying) of a Canon 1D MKIII and have an issue and some questions with which I hope some MKIII users can assist.

1. The body seemed to function properly, then as I changed from ISO 400 to 800 (in manual shutter and A), some serious banding appeared along the longest side of each image. The issue started about two frames before I switched to ISO 800 and after 100 or so O.K. images at 400.

2. The shutter has a distinctive sound, much different and more deliberate than the MKIIn. Is that normal?

3. I have no idea of its shutter count. What's the best and cheapest way to get the count?

4. How much better are the batteries? I have four or five I use with the MKIIn for football and hoops. How many now do I realistically need?

5. What improvements can I expect over the MKIIn?

6. This body is one of those that was eligible for the Canon recall. The owner said he had no issues and didn't send it in. Should and can I still get the fix and for free?

Thanks, all.

 Bob Markey II's gear list:Bob Markey II's gear list
Canon EOS-1D Canon EOS-1D Mark II N Canon EOS-1D Mark III Canon EF 50mm f/1.8 II Canon EF 85mm f/1.8 USM +4 more
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
(unknown member)
(unknown member)
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow