LF-1 Owners--help needed

Started Dec 26, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Conchita
Veteran MemberPosts: 9,909
Like?
LF-1 Owners--help needed
Dec 26, 2013

When B&H dropped the price on the LF-1, I bit. The box came and someone had obviously tried to get into it, which the UPS driver noted (said that brown B&H tape is a great temptation to people on the line because it means something valuable inside), but everything was intact inside the box so I just took delivery and called B&H to let them know it had obviously been handled pretty roughly in case there was a problem with the camera.

Well, there are some things that I think are just the camera (like the EVF--I have a high tolerance for cruddy EVFs--I had a Minolta A1 about ten years ago and there's nothing anywhere as bad as that evf was, but this is the only EVF I've ever seen that gave me eye strain after about three shots even with the diopter set properly), but there are other things that I'm wondering about, like the menus, for instance.

If I push the menu button, I can never back out of the menu again without powering off the camera. I double checked to see if there's some weird button push combination I was missing, but according to the manual I'm doing it correctly.

Is this a problem with my camera or is the software just that poor? Trying to decide if it's an exchange or a straight return at this point.

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow