My New 1DX Has Black Spots.

Started Sep 30, 2013 | Discussions thread
Shop cameras & lenses ▾
tvstaff
tvstaff Senior Member • Posts: 1,535
Re: READ THIS MAN'S 1DX STORY

I know this has been an inactive thread for a little while... I just bought a 1DX recently and I'm having some of these oil problems too it seems. The sixth digit is a 9 on mine. It has no markings. Came with 1.2.4 installed. I checked the sensor almost right away when I bought it and it was essentially perfect; couple little dust specs but that's all. There were 3 very light specs in my viewfinder (1 top left, 1 bottom left, 1 top right.) After around 500 shots or so my sensor was becoming quite dirty!! I hadn't changed the lens a single time either. I decided to give it a wet clean. Took 5 pads and was able to get it almost spotless. I was also able to remove the top left and bottom left viewfinder specs by gently using a rocket blower. However, the top right wouldn't budge. Anyways, I've taken around another 500 shots and my sensor is already showing quite a bit of oil. But what really ticks me off is the fact that I just checked my viewfinder again and now there's 3 specs in the top right corner! Seems like mine, with a 9 in the serial, has the oil problem. What a PITA.

It beez that way ;)..... Take it back.. get another. NO OTHER OPTION. I learned the hard way. Take it back if you can. Get another copy.. repeat. Take it back. Did you get that? Ok.... one more time....

 tvstaff's gear list:tvstaff's gear list
Canon EOS-1D X Canon EOS-1D X Mark II Canon EF 70-200mm f/2.8L IS II USM Canon EF 300mm f/2.8L IS II USM Canon EF 24-70mm f/4L IS USM +24 more
Post (hide subjects) Posted by
(unknown member)
ajy
(unknown member)
ajy
(unknown member)
(unknown member)
ajy
(unknown member)
ajy
ajy
ajy
ajy
(unknown member)
ajy
ajy
ajy
ajy
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow