EOS 100D/SL1 weird ISO

Started Dec 22, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
JLyng
Junior MemberPosts: 46Gear list
Like?
EOS 100D/SL1 weird ISO
Dec 22, 2013

I am very pleased with my EOS 100D but I would like to know if any other user has seen something like this.

One of my first pictures I used the setting for taking a picture of food. I still have the picture and when I check details it says it was taken using ISO 2500.

Later I took a picture using the "P" mode and the ISO ended at ISO 250

As far as I can see in the instruction book my camera doesn't even have these options  ISO 2500 , ISO 250. (When I pick the ISO manually ISO 2500 and ISO 250 is not among the numbers that I can choose).

I also bought Canon Speedlite 430exii and when I use the full automatic with the flash (ETTL-II) 5 out of 5 pictures was taken at ISO 1600.

Like I said I am pleased with my camera and I don't mind adjusting the aperture and the shuttertime if needed, but it would be nice if I sometimes could rely on the automatic too.

Is it possible that I have a faulty camera?

Jorgen Lyng

 JLyng's gear list:JLyng's gear list
Canon EOS 100D Canon EF-S 18-55mm f/3.5-5.6 IS STM
Canon EOS 100D (EOS Rebel SL1)
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow