Olympus E-M1 focus peaking is extremely laggy?

Started Dec 20, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Clyzm
Forum MemberPosts: 63
Like?
Olympus E-M1 focus peaking is extremely laggy?
Dec 20, 2013

So I'm in the market for an m43 camera. I'm ditching my 6D and lenses. I've realized that the E-M1 with a 17mm f/1.8 and 45mm f/1.8 are good enough for what I shoot and how I shoot.

However, one thing bothers me. On my 6D with magic lantern firmware installed, I've been using focus peaking A LOT with my Sigma 35mm f/1.4. It has been fantastic, dead on, and very responsive. I've also picked up and used the Sony A7, and the peaking has been great there as well. However, the E-M1 has been a whole other story. With peaking turned on, as soon as I touch the focus ring it feels like everything slows to a crawl. The rear LCD (or the EVF if I'm using that) feels like it slows down to a slide show. I tried two different bodies at two different camera stores, and both times the sales reps agreed with me regarding how awful peaking seems on the E-M1.

Am I missing something? Is peaking on the E-M1 really this bad? Is there something switched on in the menus that's causing this sort of lag? I would love some feedback from people who own or at least have used the camera, as this is a dealbreaker to me in a $1400 camera body. If this is really an issue and there is no word from Olympus, I feel like I'm better off grabbing a used E-M5 or a new A7.

Canon EOS 6D Olympus E-M1 Sony Alpha 7
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow