Nikon: Lost all camera control when attempting to use PW FlexTT5

Started Oct 12, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Joesiv
Veteran MemberPosts: 5,350Gear list
Like?
Nikon: Lost all camera control when attempting to use PW FlexTT5
Oct 12, 2013

I've tried to search for people with similar problems on google but to no avail.

I'm just trying out a FlexTT5 with my Nikon D700 to control my Einstein strobe, the manual triggering seems to work fine using the test button.  However, whenever I put the FlexTT5 on my D700 all my exposure control goes away.  When I press the shutter, my lens hunts, but won't actually exspose a shot either (going to manual focus won't allow the shutter to release either).

The exposure mode is Manual, and everything works fine before I put the TT5 on.  The little flash icon flashes though when I press the shutter.

Any ideas what could be going on

-- hide signature --

Cloverdale, B.C., Canada
Currently shooting: Nikon D3S, D700
http://www.joesiv.com

 Joesiv's gear list:Joesiv's gear list
Nikon D700 Olympus E-510 Nikon AF-S Nikkor 50mm f/1.4G Nikon AF Nikkor 105mm f/2D DC Nikon AF-S Nikkor 28mm f/1.8G
Nikon D700
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow