My New 1DX Has Black Spots.

Started 10 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
slarti bartfast
Regular MemberPosts: 334
Like?
My New 1DX Has Black Spots.
10 months ago

Two days ago i picked up a 1dx with an '8' as its 6th digit, it also has the 1.2.4 firmware already on board. After 2 days use it has over 20 black spots in the top right of the viewfinder. There is no letter "A" or any black mark on the silver bit. Before i used it i asked canon service about the lack of an "A" or black mark. They said if any problems developed they would fix it and i should not worry and just go ahead and enjoy the camera. I pushed for an answer as to -if the "fix" was already done at the assembly stage of my camera. I was told that at some stage they have to stop marking the cams with "a" and black marks because it just makes for more assembly procedures.

I tried to check the net to see at what point the 1.2.4 came out and if this was well after the "recall" then maybe mine with the 1.2.4 implemented at the assembly stage means mine is a recent body.

I walked to another camera store today and had a look at their display 1dx and it had a 7 (as it's 6th digit) and an 'A' in the batt area. So, the "a" is not just a North America thing which was another reason given by canon Australia as to why mine has no markings.

Can anyone help me clear up if mine is a recent body?. I do remember reading here that someone else hand an 8 that developed spots so, i'm not alone at least.

I will be taking it back to the shop but don't know if I should expect a replacement or let them send it off to get fixed.

slarti

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow