More Nex-6 problems

Started Sep 2, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
SteveOttwa
Forum MemberPosts: 60Gear list
Like?
More Nex-6 problems
Sep 2, 2013

I sent my Nex-6 back to Sony Canada a while ago because it would not lock focus at small apertures (above f8). It also had the problem that many others have reported where the camera seems to lose contact with the lens, white screen etc..

They apparently fixed that problem, although the only comment that came back was that it was "reset to factory settings" (or something like it). In the process I lost all my settings (of course) and all my downloaded software (grrrrr.).

Now however, a couple of other issues have appeared that weren't there before.

1)The 2Sec Self timer option has completely disappeared from the Drive mode menu ...I used to use it regularly.

2) In either Auto mode, the focus area graphic shows up multiple times in the viewfinder, and changes randomly with each touch of the shutter release. I don't normally use Auto mode, but this seems bizarre.

I do like the camera, for many reasons, but am having serious misgivings about reliability, and how smart it might be to keep investing in Nex lenses and accessories.

Has anybody else experienced any of this?

 SteveOttwa's gear list:SteveOttwa's gear list
Olympus OM-D E-M5 Olympus M.Zuiko Digital ED 75-300mm 1:4.8-6.7 Olympus M.Zuiko Digital ED 40-150mm 1:4-5.6 R Panasonic 20mm F1.7 II Olympus 12-40mm F2.8
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow