E-PL5 firmware update - please help!

Started 9 months ago | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
Pedagydusz
Veteran MemberPosts: 4,183Gear list
Like?
E-PL5 firmware update - please help!
9 months ago

I have just bought an E-PL5. So far I am enjoying the camera, apart from finding a steep learning curve due to some menu obscurity. But the LCD is really very good, everything seems to work well, and though I am primarily a RAW user I experimented with iAuto on a snow field (a difficult subject) and the result was very pleasant.

But there is one thing wrong: I can't try to find any Firmware update, because I can't connect the camera to the computer.

Computer is an iMac, OS recent (10.8.4), Olympus Viewer 1.43. When I choose "Update Camera" I get a dialogue that only gets me to a disappointing "Unable to find a Camera".

Of course, the camera is connected via the supplied cable, directly from a computer USB port. In the LCD I tried both the "Storage" position and the "MTP" position. Nothing works. The battery is freshly charged. I just can't find out what is wrong, possibly from my part.

Oh, and the camera has been registered.

Can anybody please give me a hint of what to do?

And why is Olympus still using this silly method of firmware updating? I remember using it with the E-3, was bad at the time, but at least it worked!

Please?

-- hide signature --
 Pedagydusz's gear list:Pedagydusz's gear list
Olympus PEN E-PL5 Panasonic Lumix DMC-GX7 Adobe Photoshop CS6
ANSWER:
Olympus E-3 Olympus PEN E-PL5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow