External Speedlite Control with 5DMIII

Started 9 months ago | Questions thread
cpharm86
Regular MemberPosts: 288
Like?
Re: External Speedlite Control with 5DMIII-Worked
In reply to ktownbill, 9 months ago

ktownbill wrote:

AnthonyL wrote:

cpharm86 wrote:

ktownbill wrote:

Try your speedlite on a known good camera body. Try a known good Speedlite on YOUR camera body. Try resetting the camera parameters to their default settings. (a menu function) Try removing both camera batteries for 15 min effectively resetting the processors. Do the same with the Speedlite.

-- hide signature --

Bill

Thank you Bill. I didn't think of trying to remove the batteries. Once I removed them and inserted them back in it worked. I am using the newest speedlight, 600EX-RT.

Interesting - not something I would have thought of either. I don't think I've ever had batteries out of either my camera or flash for more than the time taken to replace them. I think I might now just do just that once in a while.

It is also a good idea to turn your cell-phone off every once in a while. Various functions in the background re-boot themselves and you will oftentimes find your phone works better. An even more extensive re-boot is to remove the phone battery. The latter is only necessary when a power-down doesn't work.

I usually turn off my cell every evening. I believe in that theory also.

Glad to hear your Speedlite/Camera is back on-course!!  Will you be adding a 2nd Speedlite to your stable?  

The thought was there originally for another speedlight. There are a few items on my wish list once I can rationalize spending the money. I don't shoot that fequently for $$$ so I tend to make additions only with the money I make with this expensive hobby or should I sell something to fund the purchase.

-- hide signature --

Bill

Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow