K-5 improvements with FW 1.14.24.26 ? please report here

Started Jan 31, 2013 | Discussions thread
Kerusker
Contributing MemberPosts: 764Gear list
Like?
Re: K-5 improvements with FW 1.14.24.26 ? please report here
In reply to Ivan Gordeli, Jul 8, 2013

Ivan Gordeli wrote:

Kerusker wrote:

Pentax did not fix the AF-Fine Adjust error after taking a movie (without turning the H-5 off/on AF correction goes to zero). This indicates that Pentax is not seriously working on FW versions. I think even the K-5 II/s still has this error.

Sorry for reviving an old thread. I haven't heard of this issue mentioned above and couldn't find anything relevant in the search. Can you give more details on how it happens please?

In 2011 I mailed the following to PENTAX Germany:

vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv

K-5 FW 1.10 first still shot after a Movie has wrong AF-Fine Adjustment (AF-FA) setting

K-5 with DA 55-300mm used in P/Av-Mode with AF-FA = +10

i.e. C4/26: =2 [On] and Apply One = +10

Test-sequence:

K-5 turn Power On with Mode dial at P

  • Turn Rear e-Dial to open Aperture to max; Mode goes to Av
  • Take test shot A (like doing for AF adjustment tests)
  • Turn the Mode dial to Movie
  • Take a short Movie (or some test shots in User Mode, see below)
  • Turn the Mode Dial back to P
  • Turn Rear e-Dial to open Aperture to max; Mode goes to Av
  • Take test shot B (like doing for AF adjustment tests)
  • Take test shot C (like doing for AF adjustment tests)
  • Turn Power Off and remove the card to load the test shots to a computer.

On the computer look where the K-5 has focused.

It will be in accordance with the EXIF data of the AF-FA value:

Test shot | AF-FA value

A | +10

B | 0

C | +10

Assumed that the K-5 focusses correctly with AF-FA = +10, the test shot B has a strong Back Focus as the EXIF value indicates.

This shows: The first still shot after a Movie has wrong AF-Fine Adjustment (AF-FA) setting

The same kind of error occurs after using a User-Mode (instead of Movie) which has AF-FA off (i.e. C4/26 = 1).

Also a User-Mode with AF-FA on (C4/26 = 2) and a AF-FA value of f.ex.-5 should be checked to see what happens (test shot B may have AF-FA = -5 instead of +10).

If there are questions don't hesitate to ask.

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

PENTAX Germany confirmed the error.

There were FW versions with B, C and all subsequent shots before turning off having AF-FA = 0 also!

Hopefully it's not to hard to understand. Check yourself, If you like to.

see also http://www.dpreview.com/forums/post/38462523

 Kerusker's gear list:Kerusker's gear list
Pentax K-5 II Pentax K-5 Pentax smc DA 15mm F4 ED AL Limited Pentax smc DA* 16-50mm F2.8 ED AL (IF) SDM Pentax smc DA 55-300mm F4.0-5.8 ED
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow