Another RX100 Sensor Dust example

Started May 27, 2013 | Discussions thread
elliottnewcomb
Senior MemberPosts: 6,933Gear list
Like?
Re: RX100 Sensor Dust [FIXED!]
In reply to Michael's Photos, Jun 22, 2013

Michael's Photos wrote:

I've had an RX100 for a few months, no dust - yet. I do have one of those 52mm rings on the lens front to accept a screw-in lens hood when needed, and keep a 54mm push-on lens cap over it whenever it's not in my belt case. So maybe these measures are keeping dust out. Glad you got it fixed, but my concern is: what caused it in the first place? Without knowing that, it's possible it'll just happen again in less than a year....?...seems to me that Olympus, Panasonic, Fuji don't seem to have nearly the threads about this problem. Is this a Sony thing, or are all zooms plagued with this?

I have come to believe many cameras come with dust inside the body that does not show up during factory inspections, but moves later inside the camera and gets in the area to be involved with the image. Which means, it can happen anytime, in or out of warranty, no matter how careful.

The magfilter with a uv filter is a good way to protect the lens itself, but it does nothing to prevent dust getting down the collapsing lens barrel if that is part of what is happening.

If the yes Japan/No China suspicion is true, perhaps the people with Japanese versions would be smart to get extended warranties.

How do you know point of origin?

Elliott

 elliottnewcomb's gear list:elliottnewcomb's gear list
Sony Cyber-shot DSC-S85 Sony Cyber-shot DSC-R1 Sony RX100 Olympus Stylus 1
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow