Another RX100 Sensor Dust example

Started 11 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
rbredow
New MemberPosts: 8
Like?
Another RX100 Sensor Dust example
11 months ago

I really love shooting with the RX100 and have had it for about 10 months. It's nearly replaced my Canon DSLR for most usage--which exceeded my expectations. I just reviewed many of the other sensor dust threads for advice, but hadn't seen a example quite like mine yet.

Today, I was out fishing and took this snapshot. Obviously I missed the focus but this was F11 and I count more than 20 dust specs:

20+ dust bunnies on the sensor after 10 months of moderate use

Here is a shot of a white backing at F11, contrast adjusted (obviously):

F11, contrast adjusted to see more of the dust

With wide open aperture, they disappear.

I'm going to follow the tutorial's I've seen online here, brave the vacuum first and then see if I need to send it into Sony for repair. I believe mine was one of the earlier models (Made in Japan).

I just reviewed my 10 months worth of shots it's only in the last few months that I can see the dust in "regular" shots so it appears to be getting worse over time. I do that other commenters have noted "invites" dust like this include using the camera in a fairly wide range of environments (some dusty) and only sometimes put it in a protective bag before putting it in my pocket (I use a microfiber sunglass bag that works quite well, but I've not always used it).

I'll plan to update this thread with my findings. I welcome any input.

Rob

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow