SD Card Corrupt? Please Help

Started May 22, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Gelbvieh
Regular MemberPosts: 169Gear list
Like?
SD Card Corrupt? Please Help
May 22, 2013

I have just returned from a month long trip to Africa and image my horror on looking at my SD cards on my computer at home to find two of the cards show old images now under new numbering.

I was using Sandisk cards in a 650D and a G1X.  I had a Sandisk Extreme SDHC UHS-1 16GB 45mb/s in the 650D and a Sandisk Ultra SDHC UHS-1 8GB 30mb/s in the G1X.  Both cards had previously been used once before in the 650D and were purchased from B&H Photo so should be originals.  Both cards were formatted in each of the 650D and G1X respectively before being used for the second time and showed no photos after formatting.

On the way home I had some time to kill on the plane and decided to view my photos via an OTG cable and a card reader on my mobile phone (Galaxy SII), as I had done from time to time while away on the holiday.  For a couple of the cards, I suspect it was these two, the photos stopped coming up in the RAW viewer (CR2), just showing as blue ?.  I stopped viewing these cards, properly disconnected them and put them away.

When viewing them back home what I have on the 8GB card is about the first 30/40 photos taken in Africa, followed by the rest of card showing photos taken the only other time the card was used, in the 650D.  These photos  now show the correct numbering from the G1X but associated with an old photo, taken on another camera, with different numbering originally.  The remaining 200 odd photos do contain the odd correct photo from Africa.  On the card both RAW and JPEG images are affected.

The 16GB card is correct for about 450 images and only the last 50 odd images are affected.  Again this card had been used one previously before in the 650D. Again the new numbering is showing an old photo which orginally was numbered some 1000 photos before its new numbering.  These photos are all RAW images.  Once again it does conatin the odd correct Africa photo amongst the old images.

I happily filled both cards knowing I had reformatted them and the review on the camera as well as flicking back through them showed all was as it should be.  However luckily I also made a backup on a Colorspace Hyperdrive.  I have checked the Hyperdrive and all the photos are there as they should be, all from Africa with no incorrect intrusions.

So whilst I do have a backup I really want to know if anyone can say what and why this has happened, will it happen on these cards again i.e. should I stop using them, and can I recover my Africa photos?  Please help me.

Gelbvieh

 Gelbvieh's gear list:Gelbvieh's gear list
Canon PowerShot G1 X Canon EOS 650D Canon EF-S 17-55mm f/2.8 IS USM Canon EF 100mm f/2.8L Macro IS USM Canon EF 70-300mm f/4-5.6L IS USM +1 more
Canon EOS 650D (EOS Rebel T4i / EOS Kiss X6i)
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow