sx280hs: Battery issues - very short life of batteries, extreme discharge rates!

Started May 12, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
JJ Rodin
Contributing MemberPosts: 604
Like?
sx280hs: Battery issues - very short life of batteries, extreme discharge rates!
May 12, 2013

I used the camera a little out of the box, had an in car charger setup so charged as I drove. Battery was 'fully charged' and did some trial video and stills. I tried both the 30fps and 60fps video modes, time used was 10mins max, 15 stills rest video, battery almost depleted!!

Had a spare Chinese (are not they all?) 'high capacity-1600mh vs 1000mh std' battery, did a bit more stills and video, 2nd battery still ok (supposedly).

Fully charged all 3 batteries (Canon & 2 cheapos) using AC charger that night.

Went for a walk, did some stills (10) and some more video testing, cheapo battery that was fully charged, no more than 5 mins of video, 10 stills, battery depleted warning!!

Something seems very wrong with the sx280 and batteries!

I have the eco mode turned off, as it dims the lcd very quickly making framing hard to do, must touch button to make it bright and usuable at least with my eyes.

So 3 batteries, both the std Canon and a cheapo (other cheapo not tested to depletion yet) showing extreme discharge rates, VERY STRANGE!!

How about anyone else ??

PS: saw another user complaining of same thing, we thought it might be a charging issue, but again? Either can be the actual charger is bad OR sx280 is simply VERY bad on batterys!! Saw a review that said he was only able to get 100 stills out of the battery vs 200 Canon rating !!

ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow