D600 oil design problem - latest serial # - is it fixed ?

Started May 2, 2013 | Discussions thread
Ecniv
Regular MemberPosts: 270
Like?
Re: No, it's not 'fixed' STEVE....
In reply to Steve Bingham, May 9, 2013

Steve Bingham wrote:

opusone wrote:

Go into any merchant's forum and see new daily reports of new owners getting the same problem.

So why do you keep telling people it is? Like Thom Hogan who also told me to go ahead and order D600...because you both got good copies ?

Pretty shabby!

Edited by moderator

Hi Bart,

Your response was a little agressive. However, we have known each other as photographers for some time. I have always respected your work. In fact I even have you on my "Photographers" link page (both sites) with this introduction: Award winning and internationally published photographer Bart Aldrich takes inspiration from a wide range of visual sources and creates lasting images noted for their vibrant colors, strong composition and intimate details.

The problem with the D600 was a faulty production run where some of the shutter inclosures had too large a gap at the bottom right side - allowing dust and lubricant to enter into the sensor area. A manafacturing glitz. To fix this, the shutter mechanism, and more importantly, the housing, needs to be replaced. Here in the USA, stores like B&H have returned quite a few to Nikon USA for this repair.

-- hide signature --

Steve Bingham
www.dustylens.com
www.ghost-town-photography.com

Then explain to all of us why new production line cameras still exhibit this problem, and why so many people are still having this issue after having shutter mechanism or housing replaced?????

Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Yes!New
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow