[nx300] Continuous shooting high - Please Samsung fix this Locked

Started Apr 30, 2013 | Discussions thread
Shop cameras & lenses ▾
This thread is locked.
Regular MemberPosts: 359Gear list
Re: [nx300] Continuous shooting high - Please Samsung fix this
In reply to jennyrae, May 3, 2013

jennyrae wrote:

why you angry? why so negative? is people here in samsung forum like that and love negative feeling? maybe reason why this forum not popular because of bad people.

good to know of problem but say problem million times in repetition in every thread help solve problem? maybe ask person with problem if he done job to call samsung million times.

I stop talking to person with bad vibration now. you not good to talk and have bad manners.

I am not angry and don't have bad manners.

I just have a low tolerance for people who try to tell other what to do. If you don't like reading about it, nobody is fording you to read this forum.

I too have had problems with the NX300, and as well as posting on here, have contacted Samsung. At least one of the issues I contacted them about was addressed (partially) in the first firmware update.

But for any other problems I have, not only will I contact Samsung, but post publicly, because that problem may be a major issue for someone, and anyone looking to purchase the camera deserves to have as much information as possible.

On the flip side, I have praised this camera where it deserves it, and have posted a lot of pictures taken with it  - some of them here: http://www.flickr.com/photos/14067357@N04/sets/72157633316638447/with/8703147385/

 chrisrabe's gear list:chrisrabe's gear list
Sony a6000 Sony Alpha 7 II Sony FE 55mm F1.8 Sony FE 90mm F2.8 macro Sony FE 70-200 F4 +2 more
Post (hide subjects)Posted by
Taffy MOD
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow