Iphoto 11 always "beach balling" (lagging) Help Please :(

Started Apr 23, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
BandofBrothers
Forum MemberPosts: 85Gear list
Like?
Iphoto 11 always "beach balling" (lagging) Help Please :(
Apr 23, 2013

Hey everyone,

So I have Iphoto 11 running on my mid-2009 macbook pro (2.2ghz core 2 duo, 8gb ram, 320gb hdd) and this particular program is always getting the infamous "beach ball" when browsing my photos and using the app in general.

I have tried the usual suggestions - repair/verify permissions, and have rebuilt the database etc by holding down cmd-alt when launching iphoto too.

I did a full format and manually rebuilt the photo library from scratch a few months ago, and the problem has persisted. I have around 10,000 images in iphoto and 0 movies.

I don't want to spend money and be "forced" to upgrade to software such as Aperture, but none of the free variations out there seem to offer what I like about iphoto. I do have iphoto 09 on my old snow leapord apps disc - I can't remember but was this version much better (less laggy) than 11? If so, I am willing to format completely and rebuild my library manually into that version.

 BandofBrothers's gear list:BandofBrothers's gear list
Nikon 1 V1
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow