Faint spots on my images (E-30)

Started Mar 31, 2013 | Discussions thread
CollBaxter
Forum ProPosts: 12,386Gear list
Like?
Re: Faint spots on my images (E-30)
In reply to Pighood, Apr 1, 2013

Dust or Oil spots.

You might have to we clean the sensor. I have had to clean the E-30 twice. Fist time I used a sensor pen then had to do a wet clean.

2 weeks ago I had a spot on E-5. I took the lens of faced the camera toward the flow . Pressed the cleaning option and shook the camera then switched off. The spot had disappeared.  I know lots of people will say 'Don't do it. as you will get dust on the sensor'  well it can't harm it as it looks like you will have to do a sensor clean any way it it does not work.

Doing a wet clean on the senor is really not that difficult.

Firstly have a look at the sensor pen. http://www.bhphotovideo.com/c/product/604569-REG/Lenspen_LENSK1A_SensorKlear_II_with_Articulated.html

-- hide signature --

Collin
(Aficionado Olympus DSLR )
http://collinbaxter.zenfolio.com/
http://www.pbase.com/collinbaxter
Life is not measured by the number of breaths we take, but by the moments that take our breath away. (George Carlin)
New Seventh Wonder of the World.
http://www.pbase.com/collinbaxter/image/95297052.jpg

 CollBaxter's gear list:CollBaxter's gear list
Canon PowerShot SX230 HS Olympus E-500 Olympus E-30 Olympus E-620 Olympus E-5 +15 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow