a99 HOT SHOE does not FIT Radio Trigger and Flashes

Started Mar 28, 2013 | Discussions thread
Klipsen
Veteran MemberPosts: 6,078Gear list
Like?
It doesn't fit my flashes and radio trigger
In reply to Brian_Smith, Mar 31, 2013

Brian_Smith wrote:

Ah, gotcha...now that makes sense. Sony's Auto-Lock Shoe Adapter

ADP-AMA (or eBay equivalent) will also allow you to mount PocketWizards onto a77 and previous Sony models. I still have a bunch of these adapters which I use with NEX7. Happy I don't need those anymore with a99 and RX1.

By contrast, I would  now need adapters for my relatively new flashes (compared to all the old stuff I'm now supposed to be happy that I can finally use) and my very new Phottix TTL flash trigger. Now, you can go ahead and use Pocketwizards in dumb mode - because they don't consider Sony worth the while to support - and be happy because you don't need adapters. Those of us WHO can't afford to buy all new flashes and triggers are not pleased.

In addition, when we do get new flashes for an eventual new camera, those will have the new hotshoe, so they'll require an adapter to fit on our old receivers - or we'll have to buy a new set of those.

Brian Smith
Sony Artisan of Imagery

I can see why you're so positive about the new, old hothshoe. My next camera will be a Nikon ... all because of this unnecessary and ridiculous change of hotshoe.

-- hide signature --

Ceterum censeo soleam calidam ISO esse delendam.

 Klipsen's gear list:Klipsen's gear list
Sony Alpha DSLR-A700 Sony Alpha DSLR-A900 Sony Alpha NEX-7 Sony E 18-55mm F3.5-5.6 OSS Sony 70-200mm F2.8 G +16 more
Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow