Some X20 photos

Started Mar 24, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Frankanswe
New MemberPosts: 18
Like?
Some X20 photos
Mar 24, 2013

I bought it yesterday and have been playing around with it a little bit. I do not pretend to call myself a photographer, I am a complete photonoob coming from an old point and shoot camera that has been used on vacations etc. I must say I had a fun time today taking these photos, next step is to get to know the camera better, take more photos and read a little bit of theory and tips in general on photography.  With this in mind, I present some snaps from today. Some of them have been converted from RAW through Silkypix (I do not know much at all about that program, so the conversions might be terrible for those who know how to use it). Have also used some filters/post processing (I use a free program called "Photoscape"). The "miniature effect" photo was shot through the balcony windows so it is a bit messed up looking, but the effect still turned out pretty cool. OK, enough blabbering, here goes - just a question first: I tried using the "S-mode", set the ISO to 100 and choose 15 seconds exposure time to get some nice smooth water shots... Then I placed the cam on a flat rock, set the timer to two seconds and fired away. The camera took the picture with the long exposure time, but the image was just completely white - anyone have any idea why? Tried several times but with the same result each time, just a completely white frame, no details captured....

Fujifilm X20
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow