My Sony a99 have a big problem "Help my please"

Started Feb 25, 2013 | Questions thread
wanderingrph
New MemberPosts: 8Gear list
Like?
Re: My Sony a99 have a big problem "Help my please"
In reply to BrookerT, Mar 16, 2013

BrookerT wrote:

I had the same thing happen to me within a month of buying mine. I took it to the store where I bought it and they replaced it with a new one right away. Something to be said for buying local.

Glad to hear your new one is working just fine.  You're only the 3rd person I've researched to have a fatal error with their A99.  Who knows if that as a good thing or a bad thing right now.

Mine malfunctioned after only 4+ months of use, after being bought local (can't beat good old face-to-face human commerce, and service).  So a replacement was out of the question.  Unfortunately, it all occurred on a Saturday when B&H was closed, so I went directly to SONY for an RMA (which the store would have done anyway).  They were able to coerce me into getting the extended warranty though!  Which given the price of the body, probably should have been picked up at the point of sale.  You win this round SONY.

Seriously though, So far Sony Support haven't been too bad, almost re-reassuringly pleasing!  Lets see if they keep it up!

I'd like to hear from the OP as well, what repair solution did you come up with?

-Irfan

 wanderingrph's gear list:wanderingrph's gear list
Sony RX100 II Sony SLT-A99 Samsung Galaxy S III
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow