Epson R3000 ink marks update - not good!

Started Mar 14, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Santelia
Regular MemberPosts: 177
Like?
Epson R3000 ink marks update - not good!
Mar 14, 2013

To Joe, Toni, Bob  and others you may recall that I was having a problem with my Epson R3000 in that the printer was leaving ink marks on my prints. Well, I received the call from the local repair service that the printer was back from Epson, I picked up, spent about 2hrs trying to get it back on my home wireless system which I finally did with the help of Epson support (another long story) and quickly tried to print so that I could test for myself that it was working properly and it was not; SAME INK MARKS ON MY PRINT AS BEFORE. Actually the print came out horrible, lack of color, faded just a mess. All the local repair place could say is that Epson had provided a complete unit repair (whatever that means) because they could not tell me. I returned the printer and its going back to Epson tomorrow. I don't think the print head was ever replaced, this time sample prints with the ink marks are going back with the printer, which I thought the local approved Epson repair service had sent originally but they had not, the printer problems had been identified through phone conversations. Sorry for the long post but I wanted to provide all details, very frustrating to say the least. $400 and nothing to show for it, yet.

-- hide signature --

Sante

ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow