Help....iphoto wont open

Started Mar 9, 2013 | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
MikeGF
Regular MemberPosts: 206
Like?
Help....iphoto wont open
Mar 9, 2013

I have an imac with SL v10.6.  I was using iphoto in the morning without any problems. In the afternoon I click on the iphoto icon and nothing happens. I have tried opening it in finder with the same result.  I can locate all the photos in finder and in PSE 10 but iphoto refuses to open. Also when I insert an SD card into the built-in card reader the SD icon shows up on the desktop then nothing. The screen that usually appears asking if you want to import all photos etc. does't display. This is a real problem as I can't transfer any new photos to the computer. I have turned the computer off and on several times but it hasn't helped.
I have looked on the web and a few other people have the same problem. The advice given usually involves pressing various keys while launching iphoto. I have tried this without any success.
Any help or advice will be greatly appreciated but please keep it really simple as I am a complete computer dunce.

-- hide signature --

Mike
C&C (cash and cheques) always welcome.

Pentax Optio V10
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow